p3d

        FsPassengersP3D Frequently Asked Questions


Hit back button or click Here to see the FAQ index.

Your version of Prepar3D is outdated
You must have Prepar3D version 2.5.12943 at the least. Update Prepar3D or install another version. (3.0)







DISCLAIMER  |  ABOUT THE AUTHOR  |  CONTACT © Copyright 2017, Daniel Polli - Switzerland, All rights reserved.